BFnetworks

ATUALIZANDO VMWARE ESXI 6.5 PARA 6.7

 

PROCEDIMENTOS

  • Habilite o ssh via https
  • Permita que o firewall do esxi possa fazer requisições http com o comando abaixo:
# esxcli network firewall ruleset set -e true -r httpClient
  • Teste o comando antes de atualizar, irá mostrar os pacotes que serão atualizados:
# esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml -p ESXi-6.7.0-8169922-standard –dry-run
  • Atualize:
# esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml -p ESXi-6.7.0-8169922-standard
  • Resultado quando atualiza corretamente:
Update Result
Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
Reboot Required: true
VIBs Installed: <lista de VIBs instalados>
VIBs Removed: <lista de VIBs removidos>

TROUBLESHOOTING:

Mensagem de erro 1:

[AttributeError]
'NoneType' object has no attribute 'close'
Please refer to the log file for more details.

Solução: Permita que o firewall do esxi possa fazer requisições http, reveja os passos acima.

Mensagem de erro 2:

[InstallationError]
[Errno 28] No space left on device
vibs = VMware_locker_tools-light_10.2.0.7253323-8169922
Please refer to the log file for more details.

Solução: instale manualmente o pacote vmware_locker_tools-light…

# cd /tmp
# wget http://hostupdate.vmware.com/software/VUM/PRODUCTION/main/esx/vmw/vib20/tools-light/VMware_locker_tools-light_10.2.0.7253323-8169922.vib
# esxcli software vib install -f -v /tmp/VMware_locker_tools-light_10.2.0.7253323-8169922.vib

Mensagem de erro 3:

[InstallationError]
Failed updating the bootloader: Execution of command /usr/lib/vmware/bootloader-installer/install-bootloader failed: non-zero code returned
return code: 1
output: ERROR: ld.so: object '/lib/libMallocArenaFix.so' from LD_PRELOAD cannot be preloaded: ignored.
Traceback (most recent call last):
File "/usr/lib/vmware/bootloader-installer/install-bootloader", line 31, in <module>
import vmkctl
MemoryError
vibs = VMware_bootbank_esx-base_6.7.0-0.0.8169922
Please refer to the log file for more details.

Solução: habilite o swap para o datastore via web client como na imagem abaixo:

habilitando swap para storage

Para saber mais sobre vmware e as opções dadas aqui, visite os links no final do post.

Não sei de tudo mas gosto sempre de saber mais, caso existam erros no post ou queiram tirar dúvidas podem comentar. Obrigado.

FONTE:

https://tinkertry.com/easy-update-to-esxi-67
https://tinkertry.com/easy-upgrade-to-esxi-650a

VMWare Upgrade: [Errno 28] No space left on device


https://martinsblog.dk/vmware-cannot-update-host-with-esxcli-due-to-error-oserror-errno-28-no-space-left-on-device/

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *